Aion 64-bit isn't working with the latest Windows 10 Update (Redstone 4)

    • Tech help

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Aion 64-bit isn't working with the latest Windows 10 Update (Redstone 4)

      Hello, my computer has just updated the latest version (1803) build (17134.1) and Aion doesn't work anymore, when I hit the blue button "Run Game" on the launcher the Aion logo appears then disappears and nothing happen, there are no errors or anything else, even the AIONLOG folder is empty....


      I tried everything above :
      - I already uninstall the entire game and reinstall it again.
      - I tried both Steam and GameForge launchers and even .BAT file.
      - I have already the latest Nvidia drivers, DirectX and Visual C++ (2008, 2010, 2012, 2013, 2017) [32bit & 64bit], All .NET Framework from 2.0 to 4.7.2

      The only thing that works is forcing the game to use the 32-bit client with Aion RainMeter :asad:

      My config :
      RAM : 16GB
      SSD : 256GB; HDD : 1TB
      GPU : Nvidia GTX 850M
      CPU : Intel i7-4700HQ
      OS : Windows 10 (64-bit)
    • Try to use the NCSoft launcher and not Gameforge Live launcher, maybe it makes a difference.

      For me it is located:

      "C:\Program Files (x86)\Gameforge\NCLauncher.exe"

      as a desktop shortcut with the target parameters /LauncherID:"GameForge" /CompanyID:"11" /GameID:"AION-LIVE" /LUpdateAddr:""

      It is basically what the Gameforge Live launcher launches:

      But those splash screen crashes only happen for me, when I use the Gameforge Live Launcher. By running NCLauncher directly via shortcut I don't have that problem.

      The post was edited 2 times, last by Click ().

    • I have already seen this solution in another thread and same thing happen.. :/

      "C:\Program Files (x86)\Steam\steamapps\common\AION\NCLauncher.exe" /LauncherID:"GameForge" /CompanyID:"11" /GameID:"AION-LIVE" /LUpdateAddr:""

      The post was edited 1 time, last by Yox ().

    • Hi guys,

      Iv been looking through the forums on how i can set up aion with windows 10. I am a returning player after 5 years and I downloaded parallel on my MAC which had windows 10 and it didnt work. (i used to have a gaming pc back then) . I got the same thing as OP, but the logo just stayed there.

      after checking out most forums and reddits i honestly got confused. i am looking to invest into a gaming laptop and was wondering if you can give any advice on how i can avoid running into this problem if i am getting a 2018 gaming laptop?