Pinned Bug/ Weird stuff reports 6.0 Beta

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Akito wrote:

      Akito wrote:

      Kery wrote:

      Akito wrote:

      Can't exchange Powerful Ancient Rune Tribe Relic. The npc don't wanna change it for ap. I put it in the selling window and it give me back the relic D:
      Reached AP Cap maybe?
      Didn't exchange any ap yet cause npc don't loves me :( I have 0 AP so...
      Ok, now it works. Maybe was a problem cause I hadn't activated the gp yet. :|
      i think the firs time you tried to exchange the relics you where under lvl 45 and the lvl limit prevents you from exchanging them,

      idk if the old lvl limit still ON in the actual patch, if so the message should be corrected, if it's a bug it needs to be addressed
    • Wisdom cube in the cube tab has wrong order- all other vunes are gold, silver, bronze from left to right, this one is bronze, gold, silver. It's a little confusing if u get this and another cube at the very start. Obviously it doesn't work like this. Anyway I find the whole system visually unnecessary complicated and uninformative

      EDIT: why has cubes list on the left different names than cubelets and u have to check the full name in the upper right corner to see which cube does what. Why the hell are u giving items such long names if there isnt enough space? If it is named "Protection cube" simple name "protection cubelets". You can still use monster images as a background.

      Also- why don't this cubelets simply automatically register in the cube, since they are not tradable anyway, just gold ones. Mayne let them drop into inventory only if the cubes are filled.

      Same with gear info when hovered: "MAnastone slot exp..." and "Expansion slot possible with 8 Slot St..." What does it mean? Sometimes people don't want to read patchnotes, most info should be obvious. So remove "pvp enchantment..." text and u will have 2 lines for full description and put enchantment level next to item's name, since it is already written it is pvp or pve gear, so no need to write "pvp enchantment" again and u can write "dagger (name) 5/15" it is ok and more informative and there is enough space.

      And next bug: cube lab is same as Luna instance, how did NC missed that??

      The post was edited 3 times, last by Elysorrow ().

    • The dredgion bug where if a healer queues alone (private or quick entry) they end up in a 30min+ long queue "waiting for clerics" only to end up in a group consisting solely of healers is still there. This is incredibly annoying.
    • Mentioned it already in another thread but putting it here as well; all of the geysers are really buggy, you´re trying to get to some higher areas but you just keep getting bugged inside the geyser, and only after like 5 minutes of being inside you can be lucky to finally get thrown to the appropriate height; pointless geyser spots at this point.
    • Hello @Galeas we are waiting for the Divine Fortress to appear right now! Its Tuesday and the fortress is vulnerable but there is no portal! @Sphyrel
      Nexus: Zach (Asmodian Cleric) 2012-2014
      Spatalos: Maurine (Elyos Gunner) 2014-2015
      Telemachus --> Deyla: Finland (Asmodian Cleric) 2015-2016
      Grendal --> Antriksha: Cersei (Asmodian Bard) 2017-2018
      Nergal: Max (Elyos Cleric) 2018-Present
    • You had it in the past? what you mean? we speak about PTS not about Normal Server :P and after 76lvl no one can loot invisible corpse for the quest item, same problem they was on russian server when you kill last boss after 76lvl is not spawn the corspe for loot or the xp balls, is not about spawn corspe and you can not loot it is when you kill the last boss is not appear corspe for loot at all in the end
    • Alamos wrote:

      In Luna Instance Daily "Hell pass" after 75 lvl it have bug and when you kill last boss is not spawn the corpse for loot the quest item. Same Problem was on Korean and on Russian server and the have put to loot the Corpse in Begine of isntance

      Russian Server Screenshot:

      Yep they had exact same problem on the Russian server and they had to put the chunk of meat at the start. Maybe we're getting the same hotfix too?
    • Some Aethertech related bugs:

      The hook in Mirash often bugs (hook gets used, skill on cooldown yet you're still at the bottom) while you're mounted in the mech.
      The skill description for bludgeon is missing a second part: reduces attack speed and magical accuracy for 10 seconds (since it got combined with weakening sting)
      Aim, Shoot, Reload, Repeat :sniper:
    • The cutscenes of asmodian campaign inside Makarna isntanse is mixed with the elyos one. In speech / voice they mentioning "Killios" NPC which is in the elyos version, but later we see "Aimah" instead (the correct asmo NPC).

      90% of game's cutscenes need desperately a fix, sometimes no sound, and if it is, their speech doesn't match the subtitles.
      Legend of the Kaisinel Temple